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Abstract  The traditional cascading menu, commonly used in most desktop applications to traverse hierarchical 
menu systems, can be a time consuming and difficult task. In particular, the wider the submenu the more difficult it 
becomes to navigate the constraints of a menu item to reach the submenu. As a consequence, the submenu may 
disappear requiring additional attempts to attain the submenu. When a target menu items resides several layers deep, 
the required navigation can produce inefficient time and distance management. In this paper, we present an 
innovative cascading menu called the zigzag menu to address these issues. In the zigzag menu, submenus appear in 
alternating directions reducing the navigational distance to reach a submenu. A user study confirmed that a zigzag 
cascading menu effectively reduces the total mouse traversal required and decreases navigational time as familiarity 
with the system increases. 
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1. Introduction 
Menu navigation is a common task that computer users 

perform frequently when using the operating system, 
browsing the net or using any desktop software. This 
navigation gives us access to different features of an 
application or various contents in a website. Mice and 
touch pads are commonly used navigation tools. Usually 
menu systems are designed in cascading fashion where 
similar operations are grouped under some main menu 
items. Then submenus are grouped under those main 
menus for operations that can be viewed as subtasks under 
the main operations. 

The accepted standard for menu traversal upholds 
submenu appearance in the rightward direction up until 
the edge of the display area is reached at which point 
submenus appear on the left. This traditional cascading 
menu, used in most GUI-based systems, poses several 
problems to users. To reach a submenu, a user must 
navigate the cursor the entire width of a menu item to 
obtain the submenu. In hierarchical menu systems, this 
navigation becomes a sequence of tunnel steering tasks. 
The longer the traversal the more difficult and inefficient 
the tunnel-steering task becomes [1,2]. During a lengthy 
traversal, a user may drift outside of the activation region 
of the parent menu item causing the submenu to disappear. 
This demands further attempts to reactivate and reach the 
submenu – a frustrating GUI task, which requires 
significant amount of neuromuscular focus. The 
traditional cascading menu approach, with each submenu 

appearing to the right of its parent, introduces another 
problem. This approach lends itself to lengthy traversals. 
In particular, for submenus that are several layers deep, 
the distance can be considerably lengthy and requires 
tedious manipulation of the mouse for the entire 
navigation, as exemplified in Figure 1. 

 

Figure 1. A traditional cascading menu, where each submenu appears to 
the right of its parent. The arrow shows the navigation required to reach 
the target item, “IE 3.0”, located in the fourth layer of the menu 
hierarchy 

With menu navigation being such an integral part of 
today’s GUI-based systems, we propose a cascading menu 
approach that reduces the lengthy navigations. In the 
suggested approach, for a multi-layer menu system, the 
submenus alternate between appearing to the right and the 
left of the parent menu item, Figure 2, with the first 
submenu appearing to the left of the base menu, provided 
enough screen real-estate exists in that direction. This 
approach reduces the amount of horizontal traversal 
required to reach a submenu, allowing for short and quick 
cursor movements that decreases the amount of tedious 
navigation required, while potentially diminishing 
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extraneous submenu appearances. Thus, better 
management of time and distance can be achieved using 
the suggested approach, which we call a zigzag cascading 
menu. 

 

Figure 2. The proposed zigzag approach to a cascading menu hierarchy, 
where each subsequent submenu layer is displayed in the opposite 
direction of its parent. The arrow shows the navigation required to reach 
the target item, “IE 3.0”, located in the fourth layer of the menu 
hierarchy 

2. Related Work 
Earlier techniques in studying menu navigation were 

primarily focused on menu selection of first-level items, 
where Fitts’ law [3] is more directly applicable. These 
studies focused on reducing the navigation required to 
reach a menu item. Such approaches have investigated 
using radial menus [4,5,6] or adaptive menus that 
rearrange or hide menu items, like split menus [7]. 
However, these approaches still require tunnel steering to 
reach a submenu. 

To reduce the amount of horizontal navigation required 
to reach a submenu Kobayashi and Igarashi [8,9] propose 
a vertical cascading menu structure that considers the 
direction of mouse movement. To reduce extraneous 
submenu appearances horizontal cursor movement is used 
to open and close a submenu, instead of solely depending 
on focus. In addition, a submenu is opened at the position 
of the cursor, instead of requiring the user to navigate 
across the entire width of the parent menu. Their approach 
reduces the total navigation distance, selection time, and 
navigational errors. However, the gesture-based approach 
did have a negative impact on some users. 

A novel approach suggested by Ahlstrom [10,11] uses 
force fields to help reduce navigational errors and the 
amount of time required to reach a submenu. In this 
technique, a virtual force field is used to guide and pull the 
cursor toward the submenu. The approach works like a 
magnet, the closer the cursor is to the submenu the 
stronger the pull and the quicker the cursor moves toward 
it. The suggested approach is a good idea for experienced 
users who already know their navigational path. However, 
while browsing the menu items an unsuspecting user may 
be pulled toward the wrong submenu due to an inclination 
toward that submenu. In contrast to the approaches of 
Kobayashi & Igarashi and Ahlstrom, our approach opens 
submenus based on the more traditional focus approach, 
without having to try to predict the intention of the user. 

James Kalbach and Tim Bosenick [12] carried out a 
study to find evidence of menu navigation dexterity in 
websites based on menu location - either on the left or on 
the right side of a page. They concentrated on finding out 
if placement of menu items on left or on right side of a 
web page has any significant performance differences in 
terms of time to reach and activate a menu. Their study 
showed no considerable variations in time taken to 
complete navigation tasks by the participants whether 
menus were placed on the left or the right side. 

3. A Zigzag Cascading Menu 
To address the problems with lengthy menu navigations 

in a traditional cascading menu, we propose an approach 
that modifies the placement of the submenu. 

A submenu is obtained by traversing a menu item in the 
direction of the submenu until the submenu is reached. 
Even in a menu hierarchy that is not very deep, this 
typically requires a lengthy horizontal navigation to the 
right. For application-based menus, originating from the 
menu bar, this is a consequence of the initial menu group 
being much wider than the menu item in the menu bar, as 
exemplified by the menu group under the View menu bar 
item in Figure 1. Regardless of where the user selects a 
menu item in the menu bar a lengthy traversal to a 
submenu is required. The problem is similar for popup 
menus, where the upper-left corner of the menu originates 
from the cursor position when the popup menu is activated. 

 

Figure 3. The working process of zigzag cascading menu 
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In both instances, even when a user must navigate to a 
menu item located lower in the parent menu group, the 
movement is mostly vertical and tends to stay toward the 
left edge of the menu group. With the users’ cursor likely 
near the left edge of a menu, a left-appearing submenu 
could be reached with a much shorter traversal, as 
exemplified in Figure 2. Once the cursor reaches the 
submenu, with a quick and short mouse movement, the 
cursor can be navigated along the vertical axis to reach the 
target menu item. If the navigation requires the display of 
another submenu, with the cursor oriented to the right of 
the current submenu, the following submenu will appear 
to the right. For subsequent submenus, the alternating 
approach continues. 

The alternating approach causes back-and-forth cursor 
movement, or a zigzag effect. The zigzag approach 
confines user movements to a much smaller region, thus, 
reduce the navigational length to reach a menu item, while, 
in theory, reducing errors by enforcing shorter steering 
movements. 

4. Evaluation 
A user study was performed to compare the traditional 

approach to the proposed zigzag approach to navigating a 
cascading menu hierarchy. The details of this study follow. 

4.1. Participants and equipment 
A total of 80 volunteers participated in the survey. Sixty 

(60) participants were undergraduate students from the 
CSE & IT department of the University of Information 
Technology and Sciences. Among the rest, there were 5 IT 
professionals and fifteen (15) service holders at different 
sectors. All participants were familiar with using a mouse 
to navigate a cascading menu. Their navigation skill was 
on an average four on a scale of five according to their 
responses. All the participants were right handed and used 
mouse with right hand. One exception was a right handed 
participant who used mouse with left hand. 

There were both desktop PCs and laptops used by the 
participants of this survey. Sixty (60) participants used 
corded, standard two-button optical scroll-wheel mouse; 
four participants used cordless mouse and the other 10 
participants of our study used touchpad on their laptops. 
Forty six (46) of the devices used had screen resolution of 
1366x768 while 33 of them had screen resolution of 
1024x768 and one had 1624x768. 

4.2. Experiment 
The user study consisted of three separate cascading 

menu navigational approaches: the traditional approach, 
the zigzag approach, and a left-only approach where each 
submenu appears to the left of its parent. The menu 
system was created in a web page with the menu bar 
centered horizontally in the page to ensure that each 
submenu appears in the desired direction without 
encountering the edge of the screen. 

All the menu systems were developed using javascript, 
CSS and HTML with same menu items in each system. 
Javascript was also used to calculate the time (in ms) and 
the distance traveled (in pixels) when a user reached a 
target menu item.  The time and the distance were shown 

(Figure 4) in a message box for users to log them at the 
end of each menu traversal task. Google chrome was used 
as the browser to render the menu systems. 

 

Figure 4. A message box to show the time and distance for users to log 
at the end of each menu traversal task 

Since zigzag menu was a novel system that the users 
were not familiar with, we had to make sure that we 
removed cognitive latency out of the equation. To 
accomplish that each participant went through a warm-up 
practice session consisting of three sets of menu traversal 
tasks – one for each cascading menu approach. This was 
practiced by each participant and through this they were 
made familiar with the zigzag menu and the left opening 
menu. 

The menu targets used for each approach were identical. 
The hierarchical levels of the target items consisted of 4 
two-level, 1 three-level and 3 four-level.  

Each participant was briefed on the purpose of the 
study and given a demonstration of the three approaches. 
During each study the participant was presented a target 
menu item to select, specified in the following format: 
MenuBarItem -->MenuItem -->SubmenuItem --
>TargetItem. Users were given 8 identical menu traversal 
tasks for each menu systems. 

The users were allowed to study the specified path 
before beginning the menu selection process. The data 
collected for each menu selection was the total time and 
the total number of pixels traversed to navigate to a target 
item. The starting point for each measurement was the 
selection of the menu bar item and concluded with the 
selection of the target item. At the conclusion of all three 
studies each user filled out a questionnaire regarding their 
experience. 

5. Results 
As mentioned earlier, we have considered two aspects 

while tabulating the results. The data collected for each 
menu selection was the total time and the total number of 
pixels traversed to navigate to a target item. The results of 
the study are shown in Figure-5 & 6 with charts of the 
percentage of the participants who required least time and 
distance to perform each task. The charts show the 
comparison among three cascading menu systems. For 
example- to perform the task in step 1, among 80 
participants 50, 17 and 13 people required least time in the 
zigzag approach, left-only approach and the traditional 
approach respectively. So, the percentages of the 
participants who required least time are 62.5%, 21.25% 
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and 16.25% accordingly. The percentage of the 
participants who required least distance in any of the 
menu system at each step is also calculated in a similar 
fashion. 

Figure 7 & 8 shows the average time and distance of 
the participants to perform each of the tasks using three 
navigation approaches, thus demonstrating comparisons 
among them. 

 

Figure 5. Participants’ percentage of who require least time of each cascading menu 

 

Figure 6. Participants’ percentage of who require least distance of each cascading menu 

6. Discussions 
The results of the user study cleary shows that the 

Zigzag approach requires the least amount of cursor 
movements and also the least amount of time for menu 
navigation. Both these findings are relevant to both Fitts’ 
law and the Steering law.  

In the report session of the survey, there were 8 
navigation tasks for collecting data. In each of these tasks, 
there were three cascading menus - traditional, left-
popping and Zig-Zag. The eight tasks included target 
menu items with varying depths - four-level, two-level, 
three-level, four-level, four-level, two-level, two-level and 
two-level. The navigation tasks are listed below -  
•  File-> New-> Business Letter-> Create from 

Templates-> Template 2 and click. 

•  File-> Convert File-> To DOS and click. 
•  Edit-> Clear Content-> Clear All-> Keep a Copy in a 

Temp File and click. 
•  View-> View File As-> View File as Web Page-> 

View in IE-> IE5.1 and click 
•  Tools-> Spelling and Grammar-> Check Both-> 

Check Whole Document -> Use Auto-correct and 
click. 

•  Options-> Show Toolbar-> On the Left and click. 
•  Help-> Contact Vendor-> Get Phone Number and 

click. 
•  View-> Decrease Font Size-> By 20% and click. 
Comparing results among three menu system from 

Figure 7 & Figure 8, we find that, in each task the average 
time and distance needed for Zig-Zag menu were 
considerably lower than those in other systems. It also 
means that most of the participants needed least time and 
distance under this new approach. It is also evident from 
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the data that most participants took lesser and lesser times 
and distance as they moved toward task at the lower end 
of the list. This proves an important fact that our 
efficiency in a particular task increases with repetition and 
increased familiarity. Most particpants were accustomed 
to the submenu appearing to right. The difference between 
traditional and left-popping menu is not higher as these 
two menus are quite similar to each other. The only 

difference between these two have is that traditional 
menu’s submenu appears in right and left-opening menu’s 
submenu appears in the left. In Zigzag menu, menu 
opened in alternating directions, which was totally new to 
the participants. But as they used the system more and 
more, they requires lesser and lesser time and distance for 
reaching target menu items. 

 

Figure 7. Participants’ average time in different steps of each cascading menu 

 

Figure 8. Participants’ average distance in different steps of each cascading menu 

While we assess the average of participants’ average 
time and distance for each cascading menu, we also find 
that both the average time and distance of Zigzag menu is 
always the lowest in every step than that of the traditional 
menu and left-opening menu. 

From the above statistics, we can see that in step 2 
where no of level is 2, the percentage of people taking the 

least time is 58.75. In step 3, for level 3 the time should 
have been more, rather the time is reduced and the 
percentage is 56.25. In the same way, while the time is 
assumed to be reduced in regard of level 4, it rather being 
the same in step 4 or reduced even more in step 1 where 
the percentage is 62.50.From the collected data, it is also 
noticeable that though the time required for level 3 or 4 
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would be comparatively higher than level 2, but in reality 
it required less time. This indicates that with increasing 
depths of the target menu, the time required by Zig-Zag 
menu is decreased gradually.  

10 regular users of touchpad devices also participated in 
the exact exercise involving laptops. Data collected from 
that experiment shows similar patterns as those collected 
from desktop PCs. 

Table 1. Percentage of least time required by participants for different step and level for Zigzag Menu 
Step 
No. 

No. of 
Level 

Participants’ Percentage of time 
(Traditional) 

Participants’ Percentage of time 
(Left-opening) Participants’ Percentage of time (Zigzag) 

1 4 16.25 21.25 62.50 
2 2 21.25 20.00 58.75 
3 3 26.25 17.50 56.25 
4 4 21.25 22.50 56.25 
5 4 13.75 23.75 62.50 
6 2 20.00 27.50 72.50 
7 2 10.00 30.00 60.00 
8 2 12.00 22.50 65.00 

7. User Feedback 
After the user study each participant filled out a short 

questionnaire asking for feedback regarding the suggested 
approach. Zig-Zag menu is more suitable to use and it 
does not takes more time or distance navigation. The 
participants think, Zig-Zag menu will be the best if this 
can be used as traditional. Then it will be faster and 
swifter than the other two. They highly appreciate the Zig-
Zag menu. 

However, the majority of participants were generally 
pleased with the zigzag approach. While comparing these 
two menus with Zig-Zag menu, the comfort and easy 
mode felt by the user is focused. Though there were some 
negative and neutral comments on Zig-Zag menu, most 
participants commented positively, such as- 
•  To me, zig zag menu is more suitable to use, though 

it takes more time due to less practice. I think, zig-
zag menu will be the best if this can be used as 
traditional. Then it will be more fast and swift than 
the other two. I am highly appreciating the zig zag 
menu.” 

•  Simple and Faster.”  
•  Zig Zag menu is the best among three menus.”  
•  Feeling comfortable with zig zag, good initiative.” 
•  Enjoyed. Let's see how its work in future.” 

 

Figure 9. Feedback Percentage of Participants Regarding Zigzag Menu 

8. Conclusion 

Our study shows that the zigzag approach we suggest 
for traversing a cascading menu system provides a 
substantial reduction in time and distance compared to the 
more traditional method. These findings are completely in 
line with the expectations of Fitt's law and the Steering 
law. Our survey shows positive feedback from users 
toward the ZigZag menu system. It can also be safely 
suggested that as users become more familiar with the 
zigzag scheme a significant decrease in time will result. 
This new menu system can be a better alternative to the 
traditional system and can be used as the default scheme 
for any GUI application. In the future, we intend to study 
this system under tablet PCs. 
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